1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Spartan Turn Signal Help

Discussion in 'Intermediate CJ-5 and CJ-6 Tech' started by redman11, Aug 20, 2013.

  1. Aug 20, 2013
    redman11

    redman11 New Member

    Joined:
    Aug 9, 2013
    Messages:
    4
    I have a 74 CJ5 Renegade with spartan turn signal on the column. Looks to be original. Blinkers work in the front, and indicators work in the cluster. However, when turning right the flashers come on in the rear, and when turning left i get nothing in the rear.

    any ideas?

    Thanks for the help!
     
  2. Aug 20, 2013
    johneyboy03

    johneyboy03 The green beast

    Quebec, Canada
    Joined:
    Jan 15, 2011
    Messages:
    1,570
    Good ground everywhere?
     
  3. Aug 20, 2013
    jdarg

    jdarg Member

    SE Wisconsin
    Joined:
    Jan 27, 2010
    Messages:
    82
    Do both rear lamps come on when you hit the brake? How about the parking lights?

    If not lit in both cases, it might be as simple as replacing the bulb. IIRC the turn signal and brake feeds share the same filament, the parking lights are on the other filament.

    You can also disconnect the Spartan at the 10-wire (i think its 10 - its pyramid shaped w/ lots of wires) plug under the dash and jumper the appropriate terminals to see if its your turn signal switch or downstream wiring.
     
  4. Aug 21, 2013
    sterlclan

    sterlclan Member Sponsor

    exploring the...
    Joined:
    Feb 21, 2009
    Messages:
    2,523
    bad ground at the housings in the rear.
     
  5. Aug 21, 2013
    Walt Couch

    Walt Couch sidehill Cordele, Ga. Sponsor

    cordele, Ga.
    Joined:
    Mar 29, 2007
    Messages:
    5,235
    If your 74 wiring is original then the turn-signal wires will go to the 4-way flasher unit and then to the individual lights. I don't know how they plug onto the four-way but if not connected properly, it can cause all sorts of problems.
     
  6. Aug 22, 2013
    DREDnot

    DREDnot Not new to JEEPS

    AZ
    Joined:
    Feb 7, 2010
    Messages:
    646
    Yeah, the problem may be in the hazard wiring. You should check out the wiring diagram in the FSM and follow it to see how it all works.
    [​IMG]
     
  7. Aug 22, 2013
    John A. Shows

    John A. Shows Comic Relief Sponsor

    Mendenhall...
    Joined:
    Sep 24, 2002
    Messages:
    907
    Could be a bad flasher couldn't it?
     
  8. Aug 22, 2013
    sterlclan

    sterlclan Member Sponsor

    exploring the...
    Joined:
    Feb 21, 2009
    Messages:
    2,523
    i still vote ground
     
  9. Aug 22, 2013
    timgr

    timgr Jeepin' Nerd Sponsor

    Medford Mass USA
    Joined:
    Aug 10, 2003
    Messages:
    18,980
    Yep - Bad grounds are common on Jeeps, and can make circuits behave in surprising ways. Just be aware, and reseat your grounds if it might make a difference.
     
  10. Sep 23, 2018
    juffer

    juffer Juffer Sponsor

    Netherlands
    Joined:
    Jun 16, 2007
    Messages:
    148
    very old post , but may be someone who can tell me where the bulb wire ( black) in the spartan is going to. The bulb is ok, but it is not working. Al functions further are ok!
    thanks
     
  11. Sep 23, 2018
    Focker

    Focker Ran when parked... Runs while moving. Staff Member Sponsor

    Tri-Cities WA
    Joined:
    Aug 18, 2014
    Messages:
    5,410
    Black --- Flasher Terminal marked "L"

    Just a heads up... This thread is in the Intermediate section, you probably found this by searching Spartan? I'm just pointing it out because I noticed you have a '69 and wouldn't want you to troubleshoot other things that may be slightly different from the intermediates
     
  12. Sep 23, 2018
    Focker

    Focker Ran when parked... Runs while moving. Staff Member Sponsor

    Tri-Cities WA
    Joined:
    Aug 18, 2014
    Messages:
    5,410
    juffer likes this.
  13. Sep 23, 2018
    juffer

    juffer Juffer Sponsor

    Netherlands
    Joined:
    Jun 16, 2007
    Messages:
    148
    Thank you. After a few hours , I found out it is the Ground. Problem solved
     
  14. Sep 23, 2018
    Focker

    Focker Ran when parked... Runs while moving. Staff Member Sponsor

    Tri-Cities WA
    Joined:
    Aug 18, 2014
    Messages:
    5,410
    It's almost always a ground. :steamed:
     
    heavychevy likes this.

Share This Page

New Posts