1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Gauges, Gas Oil.

Discussion in 'Intermediate CJ-5 and CJ-6 Tech' started by bigj, May 5, 2018.

  1. May 5, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    77 cj5 , new tank, sending unit, gauge cluster, wire checks out fine, when the key is turned on it goes to full and stays there, grounds are good.....similer problem with oil pressure, on second new sending unit, added a new gauge today, turn key on and it goes to full pressure and stays there after it is started, grounds are good, and sending wire also.
     
  2. May 5, 2018
    PeteL

    PeteL Member Sponsor

    Hills of NH
    Joined:
    Aug 3, 2003
    Messages:
    5,622
    Sure the senders and gauges are matched?
     
  3. May 5, 2018
    58 willys

    58 willys Sponsor Sponsor

    Millsboro, Delaware
    Joined:
    Jul 2, 2010
    Messages:
    780
    Who's the manufacturer of you gas sending unit if it's Crown or Omix not unusual for those not to work. I finally bought an MTD gas sending unit made here in the USA and have had no problems.
     
  4. May 5, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    I think Omix, but I hope I wasnt missing something simple. everything was ordered for a 77 cj5, so it should match, I agree with crown a Omix being trash.
     
  5. May 6, 2018
    Mark Wahlster

    Mark Wahlster Member

    Silverton, OR
    Joined:
    Dec 17, 2015
    Messages:
    387
    DID you test it before putting it in? did you adjust the swing?
     
  6. May 6, 2018
    sterlclan

    sterlclan Member Sponsor

    exploring the...
    Joined:
    Feb 21, 2009
    Messages:
    2,462
    The omix gages are no good if you look you can find nos ones get a name brand sending unit for the oil and an mts sender for the tank.are the wires to the senders new? If the wire is grounded the gage will peg full.
     
  7. May 6, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    No I did not test.
     
  8. May 6, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    The wires test good and I even ran a temperary one to double check, and I get the same result...Full...I took sending wire off tank and grounded it and I get the same result FULL. Ill try the same with the oil sender to see what happens.
     
  9. May 6, 2018
    sterlclan

    sterlclan Member Sponsor

    exploring the...
    Joined:
    Feb 21, 2009
    Messages:
    2,462
    do they peg with no sender hooked up?i recall the omix ones had a bunch that were wired wrong.
     
  10. May 6, 2018
    Walt Couch

    Walt Couch sidehill Cordele, Ga. Sponsor

    cordele, Ga.
    Joined:
    Mar 29, 2007
    Messages:
    5,155
    This... Wired wrong from the factory..
     
  11. May 6, 2018
    47v6

    47v6 junk wrecker! Sponsor

    Washington DC.
    Joined:
    Oct 25, 2006
    Messages:
    4,016
    I had a 77 cj5. Gas gauge didn't work. There are at least 2 different ones where the sender and gauges were not matched correctly. I got mine from the dealer in 1990 and had to get another one. You need to figure out the ohm range and match it.

    Could also be the the gauges or sender are faulty too though.
     
  12. May 6, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    both the oil and gas ,do not do anything with sender unhooked.
     
  13. May 6, 2018
    timgr

    timgr Jeepin' Nerd Sponsor

    Medford Mass USA
    Joined:
    Aug 10, 2003
    Messages:
    18,798
    Isolate the senders from the gauges so you can test them separately. Both the oil and temp gauges respond to changing resistance from their senders. Look at pages 3-57 and 3-58 in the '77 TSM. Get some fixed resistors (or a potentiometer) and some clip leads and substitute resistors for the senders. Disconnect the gauge and measure the resistances from the senders with your multimeter. This will identify if the problem is the gauges or the senders.
     
  14. May 6, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    Ok, I removed sending unit on gas tank, hooked it back up and moved float by hand, in down position it reads empty, start raising and it goes straight to full. took it apart and theres not a whole lot to it. who sells a good one? I have been satisfied with Summit.
     
  15. May 6, 2018
    timgr

    timgr Jeepin' Nerd Sponsor

    Medford Mass USA
    Joined:
    Aug 10, 2003
    Messages:
    18,798
    Test the gauges with fixed resistors before you condemn the sender.
     
  16. May 14, 2018
    bigj

    bigj New Member

    swanton md
    Joined:
    Feb 26, 2016
    Messages:
    30
    Got it, it was the brand new omix gauge cluster, gas gauge was defective. Luckily 4 wheel parts took it back, thanks.
     

Share This Page

New Posts