1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

55 speedo cluster

Discussion in 'Early CJ5 and CJ6 Tech' started by dauntless_powered, Sep 26, 2009.

  1. Sep 26, 2009
    dauntless_powered

    dauntless_powered SUB Chief

    Groton, CT
    Joined:
    Nov 3, 2003
    Messages:
    1,000,069
    I have tried to search, but all the links I come across are broken due to the tech section still be updated. Any have a diagram of what goes where on the back of a 55' 0-10 speedo?? I have what looks like a regulator with two posts that is mounted to the back of the gauge that needs to have power supplied to it before being distributed to the other gauges (ie: fuel/temp) any help, thanks
     
  2. Sep 26, 2009
    duke54

    duke54 Member

    JACKMAN MAINE
    Joined:
    Apr 15, 2003
    Messages:
    319
    Give Lynn PM:)
     
  3. Sep 26, 2009
    dauntless_powered

    dauntless_powered SUB Chief

    Groton, CT
    Joined:
    Nov 3, 2003
    Messages:
    1,000,069
    Thanks Duke!!
     
  4. Sep 28, 2009
    dauntless_powered

    dauntless_powered SUB Chief

    Groton, CT
    Joined:
    Nov 3, 2003
    Messages:
    1,000,069
    Anyone? Speedo works, sending units are good, but I can not get the fuel or temp in either of my two gauges to work.
     
  5. Sep 28, 2009
    sparky

    sparky done Staff Member Founder

    Toowoomba, QLD
    Joined:
    Sep 20, 2002
    Messages:
    9,059
    You can PM me with requests for articles that have yet to be restored you know. :)
     
  6. Sep 29, 2009
    dauntless_powered

    dauntless_powered SUB Chief

    Groton, CT
    Joined:
    Nov 3, 2003
    Messages:
    1,000,069
    :oops::oops: thought about it but decided not to bother you admin guys. I can re search and try to find a couple that sounded like they had good potential. Thanks!
     
  7. Sep 29, 2009
    sparky

    sparky done Staff Member Founder

    Toowoomba, QLD
    Joined:
    Sep 20, 2002
    Messages:
    9,059
    I appreciate the thought Erik.

    It only takes me a few moments to get the files ready and send them.

    I may not get it done on the exact day that you ask though.
     
  8. Sep 29, 2009
    davistroy

    davistroy Grasshopper

    Marietta, GA
    Joined:
    Jul 30, 2009
    Messages:
    432
    Not sure if this applies to you or not - Try this - it's mine from a 66 (I should have documented this when I re-wired mine!) - I think it's right but hopefully someone will correct me if it's wrong.

    Notes:
    1. The picture is upside down (i.e. the bottom of the pic is the top of the cluster)
    2. I am running a Delco 12SI - not the original Generator/Alternator
    3. The FSM sometimes shows 2 illumination lights or cluster lights - I only have one, or maybe #6 is a cluster light? Just thought of that.

    [​IMG]

    Here's a couple of other posts that helped me:

    http://www.earlycj5.com/forums/showthread.php?t=60248

    http://www.earlycj5.com/forums/showthread.php?t=67796
     
    Last edited: Sep 29, 2009
  9. Sep 29, 2009
    SIDSCJ

    SIDSCJ Jeep addict

    New Haven, Vermont
    Joined:
    Jun 25, 2004
    Messages:
    1,070
    Are you staying 6 volt or converting to 12?
     
  10. Sep 29, 2009
    SIDSCJ

    SIDSCJ Jeep addict

    New Haven, Vermont
    Joined:
    Jun 25, 2004
    Messages:
    1,070
  11. Sep 29, 2009
    dauntless_powered

    dauntless_powered SUB Chief

    Groton, CT
    Joined:
    Nov 3, 2003
    Messages:
    1,000,069
    Thanks guys, Mine does have that regulator on it and after reading that last link from Sid ( I had just found that one myself) it sounds like I am on the right track. The JEEP already has a painless kit installed so after reading that I am ok to leave the factory guages in as long as that regulator is working right?

    Davis, thanks a ton for that, that made the light hookup alot clearer even though mine is a touch different (55')
     

Share This Page

New Posts