1. Registration trouble? Please use the "Contact Us" link at the bottom right corner of the page and your issue will be resolved.
    Dismiss Notice

Hesitates When Warm

Discussion in 'Early CJ5 and CJ6 Tech' started by dave59cj5, Sep 19, 2022.

  1. Sep 19, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    Hey friends. I’ve got a 59 CJ5 that seems to stumble and hesitate after she’s warmed up. It’s got all new fuel lines, new electronic ignition, and plugs. She starts just fine but after about 10 -15 minutes while accelerating out of 1st and 2nd gear it stumbles and hesitates as I accelerate. I believe this is a solex carb but can’t confirm. Any help would be appreciated!
     
  2. Sep 19, 2022
    PeteL

    PeteL If it wasn't for physics, and law enforcement... 2022 Sponsor 2021 Sponsor 2020 Sponsor

    Hills of NH
    Joined:
    Aug 3, 2003
    Messages:
    8,734
    As they say, most carb problems are electrical... Did it do this before the electronic ignition conversion?

    I have never experienced symptoms like yours with OEM Carter YF carbs. I can't confirm but I have heard rumors of Solexes "icing" in humid conditions.
     
    Beach66Bum likes this.
  3. Sep 19, 2022
    fyrmn

    fyrmn Member 2022 Sponsor 2021 Sponsor 2020 Sponsor

    High Desert AZ
    Joined:
    Apr 29, 2006
    Messages:
    181
    Might check the accelerator pump. ?????
     
    Rick Whitson likes this.
  4. Sep 19, 2022
    Oldpappy

    Oldpappy A.C. Fults - Curmudgeon at large 2022 Sponsor 2021 Sponsor

    East Tennessee
    Joined:
    Feb 8, 2021
    Messages:
    1,012
    Need to confirm what carburetor you have which might help us help you.

    I don't know much about the Solex, but with a Carter YF the metering rod out of adjustment or stuck, or a bad accelerator pump, as already mentioned, can cause the engine to stumble on acceleration.

    Picture of a Carter YF



    Carter YF.jpeg


    And below is a picture of a Solex

    Solex.jpeg
     
  5. Sep 20, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    Thanks fellas, I believe it’s the solex. Tried to put in a picture here. The ignition was done prior to my purchase so not sure about it doing this before me. On another forum someone noticed that the choke cable was not properly secured and was possibly allowing for a partial closed choke.
     

    Attached Files:

  6. Sep 20, 2022
    Glenn

    Glenn Kinda grumpy old man Staff Member

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    12,014
    Yes, that arm should be all of the way forward when warmed up. The part that holds the cable secured is missing on yours.
     
  7. Sep 20, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    Awesome thanks, I reworked it last night but didn’t get a chance to drive it yet. Hopeful that is the issue. Thanks!
     
  8. Sep 20, 2022
    Glenn

    Glenn Kinda grumpy old man Staff Member

    Apopka, Fl
    Joined:
    Sep 21, 2002
    Messages:
    12,014
    I should have said screw, not part.
     
  9. Sep 20, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    Ya, I knew what you were talking about. Now I just gotta find a screw that’ll fit.
     
    Glenn likes this.
  10. Oct 8, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    hey everyone i got the choke linkage sorted out the way it is supposed to be but its running worse now. The carb was a little loose where the extension bolts onto the intake manifold so i tightened it down. I've been messing with the idle adjustment and the volume control screw and now it wont idle well, who would have thunk it. Are there any base adjustments for the Solex so i can start from a base line of where the screws should be positioned. I haven't' messed with the accelerator pump yet. Thanks!
     
  11. Oct 8, 2022
    Bondo

    Bondo Master General Re-Engineer,...

    Greenfield Me.
    Joined:
    Dec 17, 2021
    Messages:
    74
    Ayuh,..... That'll cause a lean condition,.... Spray ether 'round the base at idle, if it changes, it's still leakin',.... might need new gaskets,....

    If the accelerator pump ain't squirtin' enough gas, that'll cause a stumble,....
     
  12. Oct 10, 2022
    dave59cj5

    dave59cj5 New Member

    Marietta ga
    Joined:
    Sep 14, 2022
    Messages:
    6
    Ok, I reset the volume control to all the way in then backed out 1 3/4 turns per manual (even though it’s for Carter not Solex). Then I turned in the accelerator pump roughly 4 rotations. I read on another thread that the pump works well with 5 threads showing. It runs so much better with that done. A little lag still on the low end and a little rough idle still. I need to get the idle set right and get a vacuum pump to work out a few more kinds.
     
    Glenn likes this.
New Posts